New League of Legends Patcher / Launcher brokes WINE Support

For german translation scroll down!

Greetings Unix Summoners,

Riot (the company behindes League of Legends) released a new patch 2 or 3 days ago whit a complete new patcher / launcher for League of Legends.

This launcher should be the beginning of more possibilitys, but actually (especially for us WINE Users) it will break the support or the possibility to play League of Legends with WINE.

The output while starting the new launcher with WINE is everytime the same:

err:ntdll:RtlpWaitForCriticalSection section 0x542fc0 "?" wait timed out in thread 0028, blocked by 002d, retrying (60 sec

The problem gets actually discussed at the official WINE HQ and the peoples there are actually searching for a fix for that.

But not only Linux / Unix users have actually problems with the new patcher. Even Windows users posting at the League of Legends Board, that there migration process breaks down the whole game. Another person talked about, that the launcher does not open up anymore.

At least we can only hope, that Riot also allows us to use the old patcher or the WINE Community will find a fix for that… I will post it here if any news or solutions are ready!

Also, today the launchpad service created my winelol 1.3.19 PPA and now the League of Legends Patcher breaks it … too bad!

Greetings
ReCon

German translation:

Grüße Unix Beschwörer,

Riot (die Firma hinter League of Legends) veröffentliche vor 2 oder 3 Tagen einen komplett neuen Patcher / Launcher für League of Legends.

Dieser Launcher sollte der Beginn für neue Möglichkeiten im Spiel sein, aber aktuell (speziell für uns WINE Nutzer) unterbindet er die Möglichkeit League of Legends unter WINE zu spielen.

Das Ausgabe beim Start des Launcher ist immer die gleiche:

err:ntdll:RtlpWaitForCriticalSection section 0x542fc0 "?" wait timed out in thread 0028, blocked by 002d, retrying (60 sec

Das Problem wird aktuell heiß diskutiert im offizielen WINE HQ und die Leute suchen aktuell nach einer Lösung für das Problem.

Aber nicht nur wir Linux / Unix Nutzer haben aktuell Probleme mit dem neuen Patcher. Auch Windows Nutzer schreiben im offiziellen League of Legends Forum, dass der Migrationsprozess für den neuen Patcher das ganze Spiel zerstört. Eine weitere Person spricht davon, dass der Launcher seit der Umstellung überhaupt nicht mehr aufgeht.

Wir können nur hoffen, dass es uns Riot gestattet auch künftig den alten Patcher zu nutzen, oder aber dass die WINE Community eine Lösung finden wird… sobald es Neuigkeiten oder eine Lösung gibt, werde ich dies hier posten!

Außerdem hat heute der Launchpad Dienst mein winelol 1.3.19 PPA fertiggestellt und jetzt sorgt der neue League of Legends Patcher dafür, dass gar nichts mehr geht … enttäuschend!

Grüße
ReCon


One thought on “New League of Legends Patcher / Launcher brokes WINE Support

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s